System Requirements

Jan 6, 2016 at 7:46 PM
I wrote an application using NPOI 2.2.0. It works great on my system with Visual Studio 2015, but it won't run on any of the client systems. This site states the requirements as VS2010 with .NET 4.0 runtime, VS2005 or VS2008 with .NET 2.0 Runtime (SP1), vs2003 with .NET 1.1, Mono, and medium trust environment in ASP.NET.

I installed .NET 4.0 and 4.5. I then installed the "Visual Studio 2010 and .NET Framework 4 Training Kit" and Mono, but it still won't work.

Does anyone know what I need to install on the client systems other than the actual DLL libraries? I don't want to install Visual Studio to all the systems.
Jan 11, 2016 at 4:24 PM
I spoke with Tony Qu who confirmed the requirements.
The missing component is the SharpZipLib library available from https://icsharpcode.github.io/SharpZipLib/. This dll must be included with the program distribution.